const regex = /.+{x\=([0-9\.]+)\s*y\=([0-9\.]+).+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+{x\\=([0-9\\.]+)\\s*y\\=([0-9\\.]+).+', 'gm')
const str = `0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}`;
const subst = `($1, $2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);