package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+{x\=([0-9\.]+)\s*y\=([0-9\.]+).+`)
var str = `0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}`
var substitution = "($1, $2)"
fmt.Println(re.ReplaceAllString(str, substitution))
}