re = /.+{x\=([0-9\.]+)\s*y\=([0-9\.]+).+/m
str = '0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}'
subst = '($1, $2)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result