#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).+{x\=([0-9\.]+)\s*y\=([0-9\.]+).+"
Local $sString = "0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}"
Local $sSubst = "($1, $2)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)