import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+\\{x\\=([0-9\\.]+)\\s*y\\=([0-9\\.]+).+";
final String string = "0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}";
final String subst = "($1, $2)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}