// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).+{x\=([0-9\.]+)\s*y\=([0-9\.]+).+").unwrap();
let string = "0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}";
let substitution = "($1, $2)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}