# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.+{x\=([0-9\.]+)\s*y\=([0-9\.]+).+/($1, $2)/gm;t' <<< "0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}"