# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^\\]*\\[^\\]*).*$"
test_str = "Conversation with Jared Firl\\nParticipants: Jared Firl\\nJared FirlThursday, March 27, 2014 at 8:30pm MDT\\n\\nAlready got it for super cheap from a humble bundle. But thanks for the thought!\\nBen James PerryThursday, March 27, 2014 at 8:29pm MDT\\n\\nYo jared, since you were kind enough to mention the left 4 dead thingy on Christmas, Dead space is free on origin"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.