use strict;
my $str = 'Conversation with Jared Firl\\nParticipants: Jared Firl\\nJared FirlThursday, March 27, 2014 at 8:30pm MDT\\n\\nAlready got it for super cheap from a humble bundle. But thanks for the thought!\\nBen James PerryThursday, March 27, 2014 at 8:29pm MDT\\n\\nYo jared, since you were kind enough to mention the left 4 dead thingy on Christmas, Dead space is free on origin';
my $regex = qr/^([^\\]*\\[^\\]*).*$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}