package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^\\]*\\[^\\]*).*$`)
var str = `Conversation with Jared Firl\nParticipants: Jared Firl\nJared FirlThursday, March 27, 2014 at 8:30pm MDT\n\nAlready got it for super cheap from a humble bundle. But thanks for the thought!\nBen James PerryThursday, March 27, 2014 at 8:29pm MDT\n\nYo jared, since you were kind enough to mention the left 4 dead thingy on Christmas, Dead space is free on origin`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}