using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\\]*\\[^\\]*).*$";
string input = @"Conversation with Jared Firl\nParticipants: Jared Firl\nJared FirlThursday, March 27, 2014 at 8:30pm MDT\n\nAlready got it for super cheap from a humble bundle. But thanks for the thought!\nBen James PerryThursday, March 27, 2014 at 8:29pm MDT\n\nYo jared, since you were kind enough to mention the left 4 dead thingy on Christmas, Dead space is free on origin";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}