#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([^\\]*\\[^\\]*).*$"
Local $sString = "Conversation with Jared Firl\nParticipants: Jared Firl\nJared FirlThursday, March 27, 2014 at 8:30pm MDT\n\nAlready got it for super cheap from a humble bundle. But thanks for the thought!\nBen James PerryThursday, March 27, 2014 at 8:29pm MDT\n\nYo jared, since you were kind enough to mention the left 4 dead thingy on Christmas, Dead space is free on origin"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")