import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\\\]*\\\\[^\\\\]*).*$";
final String string = "Conversation with Jared Firl\\nParticipants: Jared Firl\\nJared FirlThursday, March 27, 2014 at 8:30pm MDT\\n\\nAlready got it for super cheap from a humble bundle. But thanks for the thought!\\nBen James PerryThursday, March 27, 2014 at 8:29pm MDT\\n\\nYo jared, since you were kind enough to mention the left 4 dead thingy on Christmas, Dead space is free on origin";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}