const regex = /^([^\\]*\\[^\\]*).*$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\\\]*\\\\[^\\\\]*).*$', 'g')
const str = `Conversation with Jared Firl\\nParticipants: Jared Firl\\nJared FirlThursday, March 27, 2014 at 8:30pm MDT\\n\\nAlready got it for super cheap from a humble bundle. But thanks for the thought!\\nBen James PerryThursday, March 27, 2014 at 8:29pm MDT\\n\\nYo jared, since you were kind enough to mention the left 4 dead thingy on Christmas, Dead space is free on origin`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}