// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(#+)").unwrap();
let string = "### Start of program
number = 0 ## Initialize the variable
number += 1 # Increment the variable";
let substitution = "\\/\\/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}