const regex = new RegExp('(#+)', 'mg')
const str = `### Start of program
number = 0 ## Initialize the variable
number += 1 # Increment the variable`;
const subst = `\/\/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);