$re = '/(#+)/m';
$str = '### Start of program
number = 0 ## Initialize the variable
number += 1 # Increment the variable';
$subst = "\/\/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;