# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(#+)/\\/\\//mg;t' <<< "### Start of program
number = 0 ## Initialize the variable
number += 1 # Increment the variable"