using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#+)";
string substitution = @"\/\/";
string input = @"### Start of program
number = 0 ## Initialize the variable
number += 1 # Increment the variable";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}