#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(#+)"
Local $sString = "### Start of program" & @CRLF & _
"number = 0 ## Initialize the variable" & @CRLF & _
"number += 1 # Increment the variable"
Local $sSubst = "\/\/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)