use strict;
my $str = '### Start of program
number = 0 ## Initialize the variable
number += 1 # Increment the variable';
my $regex = qr/(#+)/mp;
my $subst = '\\/\\/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";