// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?um)<h4>.*\n").unwrap();
let string = "<h4>это заголовок</h4>вот текст абзаца<h4>еще один</h4>и еще текст
<h4>Документ 21</h4>
блао бла
<h4>Документ 21</h4>
вав
<h4>Документ 21
вавфвафва </h4>
<h4>[\\s\\S]*?<\\/h4>\\n?";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}