$re = '/<h4>.*\n/um';
$str = '<h4>это заголовок</h4>вот текст абзаца<h4>еще один</h4>и еще текст
<h4>Документ 21</h4>
блао бла
<h4>Документ 21</h4>
вав
<h4>Документ 21
вавфвафва </h4>
<h4>[\\s\\S]*?<\\/h4>\\n?';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;