re = /<h4>.*\n/m
str = '<h4>это заголовок</h4>вот текст абзаца<h4>еще один</h4>и еще текст
<h4>Документ 21</h4>
блао бла
<h4>Документ 21</h4>
вав
<h4>Документ 21
вавфвафва </h4>
<h4>[\\s\\S]*?<\\/h4>\\n?'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result