#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?um)<h4>.*\n"
Local $sString = "<h4>это заголовок</h4>вот текст абзаца<h4>еще один</h4>и еще текст" & @CRLF & _
"<h4>Документ 21</h4>" & @CRLF & _
"блао бла" & @CRLF & _
"<h4>Документ 21</h4>" & @CRLF & _
"вав" & @CRLF & _
"<h4>Документ 21" & @CRLF & _
"вавфвафва </h4>" & @CRLF & _
"" & @CRLF & _
"<h4>[\s\S]*?<\/h4>\n?"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)