# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<h4>.*\n//gum;t' <<< "<h4>это заголовок</h4>вот текст абзаца<h4>еще один</h4>и еще текст
<h4>Документ 21</h4>
блао бла
<h4>Документ 21</h4>
вав
<h4>Документ 21
вавфвафва </h4>
<h4>[\s\S]*?<\/h4>\n?"