const regex = /<h4>.*\n/gum;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<h4>.*\\n', 'gum')
const str = `<h4>это заголовок</h4>вот текст абзаца<h4>еще один</h4>и еще текст
<h4>Документ 21</h4>
блао бла
<h4>Документ 21</h4>
вав
<h4>Документ 21
вавфвафва </h4>
<h4>[\\s\\S]*?<\\/h4>\\n?`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);