using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h4>.*\n";
string substitution = @"";
string input = @"<h4>это заголовок</h4>вот текст абзаца<h4>еще один</h4>и еще текст
<h4>Документ 21</h4>
блао бла
<h4>Документ 21</h4>
вав
<h4>Документ 21
вавфвафва </h4>
<h4>[\s\S]*?<\/h4>\n?";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}