# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<h4>.*\n"
test_str = ("<h4>это заголовок</h4>вот текст абзаца<h4>еще один</h4>и еще текст\n"
"<h4>Документ 21</h4>\n"
"блао бла\n"
"<h4>Документ 21</h4>\n"
"вав\n"
"<h4>Документ 21\n"
"вавфвафва </h4>\n\n"
"<h4>[\\s\\S]*?<\\/h4>\\n?")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.UNICODE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.