import Foundation
let pattern = #"^-?\d+\.?(\d+)?([eE][+-]?\d+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
42
-42
4.2
-4.2
4.2e9
4.2e+9
4.2e-9
-4.2e9
-4.2e+9
-4.2e-9
0.666
-0.666
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)