const regex = /^-?\d+\.?(\d+)?([eE][+-]?\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?\\d+\\.?(\\d+)?([eE][+-]?\\d+)?$', 'gm')
const str = `42
-42
4.2
-4.2
4.2e9
4.2e+9
4.2e-9
-4.2e9
-4.2e+9
-4.2e-9
0.666
-0.666`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);