re = /^-?\d+\.?(\d+)?([eE][+-]?\d+)?$/m
str = '42
-42
4.2
-4.2
4.2e9
4.2e+9
4.2e-9
-4.2e9
-4.2e+9
-4.2e-9
0.666
-0.666'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result