# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^-?\d+\.?(\d+)?([eE][+-]?\d+)?$"
test_str = ("42\n"
"-42\n"
"4.2\n"
"-4.2\n"
"4.2e9\n"
"4.2e+9\n"
"4.2e-9\n"
"-4.2e9\n"
"-4.2e+9\n"
"-4.2e-9\n"
"0.666\n"
"-0.666")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.