using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?\d+\.?(\d+)?([eE][+-]?\d+)?$";
string substitution = @"";
string input = @"42
-42
4.2
-4.2
4.2e9
4.2e+9
4.2e-9
-4.2e9
-4.2e+9
-4.2e-9
0.666
-0.666";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}