# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^-?\d+\.?(\d+)?([eE][+-]?\d+)?$//gm;t' <<< "42
-42
4.2
-4.2
4.2e9
4.2e+9
4.2e-9
-4.2e9
-4.2e+9
-4.2e-9
0.666
-0.666"