import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?\\d+\\.?(\\d+)?([eE][+-]?\\d+)?$";
final String string = "42\n"
+ "-42\n"
+ "4.2\n"
+ "-4.2\n"
+ "4.2e9\n"
+ "4.2e+9\n"
+ "4.2e-9\n"
+ "-4.2e9\n"
+ "-4.2e+9\n"
+ "-4.2e-9\n"
+ "0.666\n"
+ "-0.666";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}