import Foundation
let pattern = #"this(?(_star)\s*|)(?P<_star>[\w\s]{,10}?)?(?(_star)\s*|)(?(_star2)\s*|)(?P<_star2>[\w\s]{10,})?(?(_star2)\s*|)ok$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this is great hyes jljladsf dsaf ljaldsjlfjoiuajdsflj ok
this is (\w+\s+)?(?(1)\s|\w)
this *
*10
*1,2
*2
*2,10
*,10
(?(_star)\s*|)(?P<_star>[\w\s]{10}?)?(?(_star)\s*|)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)