using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"this(?(_star)\s*|)(?P<_star>[\w\s]{,10}?)?(?(_star)\s*|)(?(_star2)\s*|)(?P<_star2>[\w\s]{10,})?(?(_star2)\s*|)ok$";
string input = @"this is great hyes jljladsf dsaf ljaldsjlfjoiuajdsflj ok
this is (\w+\s+)?(?(1)\s|\w)
this *
*10
*1,2
*2
*2,10
*,10
(?(_star)\s*|)(?P<_star>[\w\s]{10}?)?(?(_star)\s*|)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}