use strict;
my $str = 'this is great hyes jljladsf dsaf ljaldsjlfjoiuajdsflj ok
this is (\\w+\\s+)?(?(1)\\s|\\w)
this *
*10
*1,2
*2
*2,10
*,10
(?(_star)\\s*|)(?P<_star>[\\w\\s]{10}?)?(?(_star)\\s*|)';
my $regex = qr/this(?(_star)\s*|)(?P<_star>[\w\s]{,10}?)?(?(_star)\s*|)(?(_star2)\s*|)(?P<_star2>[\w\s]{10,})?(?(_star2)\s*|)ok$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}