import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "this(?(_star)\\s*|)(?P<_star>[\\w\\s]\\{,10\\}?)?(?(_star)\\s*|)(?(_star2)\\s*|)(?P<_star2>[\\w\\s]{10,})?(?(_star2)\\s*|)ok$";
final String string = "this is great hyes jljladsf dsaf ljaldsjlfjoiuajdsflj ok\n\n\n"
+ "this is (\\w+\\s+)?(?(1)\\s|\\w)\n\n"
+ "this * \n\n\n"
+ "*10\n"
+ "*1,2\n"
+ "*2\n"
+ "*2,10\n"
+ "*,10\n\n"
+ "(?(_star)\\s*|)(?P<_star>[\\w\\s]{10}?)?(?(_star)\\s*|)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}