const regex = new RegExp('this(?(_star)\\s*|)(?P<_star>[\\w\\s]{,10}?)?(?(_star)\\s*|)(?(_star2)\\s*|)(?P<_star2>[\\w\\s]{10,})?(?(_star2)\\s*|)ok$', 'gm')
const str = `this is great hyes jljladsf dsaf ljaldsjlfjoiuajdsflj ok
this is (\\w+\\s+)?(?(1)\\s|\\w)
this *
*10
*1,2
*2
*2,10
*,10
(?(_star)\\s*|)(?P<_star>[\\w\\s]{10}?)?(?(_star)\\s*|)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}