#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)this(?(_star)\s*|)(?P<_star>[\w\s]{,10}?)?(?(_star)\s*|)(?(_star2)\s*|)(?P<_star2>[\w\s]{10,})?(?(_star2)\s*|)ok$"
Local $sString = "this is great hyes jljladsf dsaf ljaldsjlfjoiuajdsflj ok" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"this is (\w+\s+)?(?(1)\s|\w)" & @CRLF & _
"" & @CRLF & _
"this * " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*10" & @CRLF & _
"*1,2" & @CRLF & _
"*2" & @CRLF & _
"*2,10" & @CRLF & _
"*,10" & @CRLF & _
"" & @CRLF & _
"(?(_star)\s*|)(?P<_star>[\w\s]{10}?)?(?(_star)\s*|)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")