# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"this(?(_star)\s*|)(?P<_star>[\w\s]{,10}?)?(?(_star)\s*|)(?(_star2)\s*|)(?P<_star2>[\w\s]{10,})?(?(_star2)\s*|)ok$"
test_str = ("this is great hyes jljladsf dsaf ljaldsjlfjoiuajdsflj ok\n\n\n"
"this is (\\w+\\s+)?(?(1)\\s|\\w)\n\n"
"this * \n\n\n"
"*10\n"
"*1,2\n"
"*2\n"
"*2,10\n"
"*,10\n\n"
"(?(_star)\\s*|)(?P<_star>[\\w\\s]{10}?)?(?(_star)\\s*|)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.