$re = '/this(?(_star)\s*|)(?P<_star>[\w\s]{,10}?)?(?(_star)\s*|)(?(_star2)\s*|)(?P<_star2>[\w\s]{10,})?(?(_star2)\s*|)ok$/m';
$str = 'this is great hyes jljladsf dsaf ljaldsjlfjoiuajdsflj ok
this is (\\w+\\s+)?(?(1)\\s|\\w)
this *
*10
*1,2
*2
*2,10
*,10
(?(_star)\\s*|)(?P<_star>[\\w\\s]{10}?)?(?(_star)\\s*|)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);