import Foundation
let pattern = #"^PT(\d+H)?(\d+M)?(\d+S)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
PT1H37S
PT1H30M15S
PT0S
PT1H0M0S
PT22H41M59S
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)