const regex = /^PT(\d+H)?(\d+M)?(\d+S)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^PT(\\d+H)?(\\d+M)?(\\d+S)?$', 'gm')
const str = `PT1H37S
PT1H30M15S
PT0S
PT1H0M0S
PT22H41M59S`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);