import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^PT(\\d+H)?(\\d+M)?(\\d+S)?$";
final String string = "PT1H37S\n"
+ "PT1H30M15S\n"
+ "PT0S\n"
+ "PT1H0M0S\n"
+ "PT22H41M59S";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}