using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^PT(\d+H)?(\d+M)?(\d+S)?$";
string substitution = @"";
string input = @"PT1H37S
PT1H30M15S
PT0S
PT1H0M0S
PT22H41M59S";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}