package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^PT(\d+H)?(\d+M)?(\d+S)?$`)
var str = `PT1H37S
PT1H30M15S
PT0S
PT1H0M0S
PT22H41M59S`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}