# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^PT(\d+H)?(\d+M)?(\d+S)?$//gm;t' <<< "PT1H37S
PT1H30M15S
PT0S
PT1H0M0S
PT22H41M59S"